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Agenda 

 Gerber 비교 

 Gerber와 Design Data간 비교 

 Differential View 

 Netlist 비교 
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Gerber Compare 

 Expedition에서 Gerber를 그래픽적으로 비교하는 기능입니다. 
— Board Station Gerber vs. Expedition Gerber 비교 

— Expedition Gerber vs. Expedition Gerber 비교 

— Expedition Design vs. Expedition Gerber 비교 
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Gerber Compare 

 Expedition PCB에서 Gerber를 다음과 같이 불러옵니다. 
— Fablink XE 또는 Fablink XE Pro License 필요 
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Gerber Compare 

 Expedition PCB에서 Gerber가 생성되는 폴더를 인식해서 

생성된 Gerber를 자동으로 불러옵니다. 또는 Gerber가 위치한 

폴더를 선택할 수도 있습니다.  (비교 대상 Gerber를 동일한 

방법으로 불러옴) 
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Gerber Compare 

 User Draft Layers에서 불러온 Gerber를 확인 할 수 있습니다. 
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Gerber Compare 

 Analysis > Gerber Compare 실행 
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Gerber Compare 

 비교 확인 
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GER_EtchLayer3 GER2_EtchLayer3 
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Gerber Compare 

 비교 확인 
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GER_EtchLayer3 + GER2_EtchLayer3 Result_Layer3 
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GERBER와 DESIGN DATA간 비교 
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Gerber 출력 전 준비사항 

12 

 DRC (Batch DRC 포함) Check를 한 후, Review Hazards에서 
Unrouted / Partial Net 항목 등을 확인합니다. 
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IPC-D-356 Netlist를 사용한 Gerber와 디자인 
데이터간 Open/Short 검증 방법 

 IPC-D-356 Format은 Bare Board Testing용으로 사용되며, 

Netlist 형식으로 표현됩니다.  

IPC-D-356 Format을 사용하여 PCB의 Open/Short 검증을 할 

수 있으며, 이러한 Open/Short 검증은 PCB 설계 프로세스에 

포함하여야 할 단계이기도 합니다. 

 IPC-D-356은 다음과 같이 3가지 Format이 사용되고 있습니다. 
— IPC-D-356 

http://www.downstreamtech.com/Support_CAM/Advisories/IPCD356_Simplified.pdf 

— IPC-D-356A 

http://www.solidigm.com/downloads/ipc356a.pdf 

— IPC-D-356B 

http://www.ipc.org/TOC/IPC-D-356B.pdf 

 Expedition PCB에서는 IPC-D-356과 IPC-D-356B Format을 

출력 할 수 있음. 
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* IPC: Institute For Interconnecting And Packaging Electronic Circuits 

http://www.downstreamtech.com/Support_CAM/Advisories/IPCD356_Simplified.pdf
http://www.solidigm.com/downloads/ipc356a.pdf
http://www.ipc.org/TOC/IPC-D-356B.pdf
http://www.ipc.org/TOC/IPC-D-356B.pdf
http://www.ipc.org/TOC/IPC-D-356B.pdf
http://www.ipc.org/TOC/IPC-D-356B.pdf
http://www.ipc.org/TOC/IPC-D-356B.pdf


©  2010 Mentor Graphics Corp.  

www.mentor.com/pcb 

IPC-D-356 Netlist를 사용한 Gerber와 디자인 
데이터간 Open/Short 검증 방법 

 범용적인 CAM 툴에서 Open/Short 테스트를 하는 절차는 

다음과 같습니다. 
1) Gerber Data를 입력해서 Gerber Netlist 생성 

2) IPC-D-356 Netlist 입력함 

3) Gerber Netlist와 IPC-D-356 Netlist를 비교해서 Open/Short을 검증함. 

 IPC-D-356 Netlist는 디자인에서 추출된 파일이며 이 파일을 

생산데이터인 Gerber와 비교해서 Open/Short 여부를 확인 

함으로써 디자인과 Gerber간의 오류 유무를 판별할 수 가 

있습니다. 

 또한, 멘토의 DFM 전문 툴인 vSure를 사용하면 손쉽게 

Open/Short 검증이 가능합니다. 
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OPEN, SHORT 검증을 위한 데이터 구성 

15 

1 2 원본 디자인 데이터 Gerber 데이터에서 OPEN, SHORT 생성 

OPEN 포인트 

SHORT 포인트 

TLW2011, Oct 2011 
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IPC-D-356 Netlist 출력 방법 

 Expedition에서 Report Writer로 IPC-D-356 data를 생성하는 방법은 다음과 

같습니다. 

16 

1 Output > Report Writer를 실행 2 Physical board data를 선택 후 OK 

TLW2011, Oct 2011 
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IPC-D-356 Netlist 출력 방법 

17 

3 Report Writer가 실행되면 Tools > Launcher를 실행 

TLW2011, Oct 2011 
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IPC-D-356 Netlist 출력 방법 
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4 실행된 Launcher에서 IPC-D-356을 선택 
후 Run을 클릭 

5 IPC-D-356 Generation창이 실행되면 
OK를 클릭 

PCB\vbreport\output\ipc356.ipc 파일이 생성 

TLW2011, Oct 2011 
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CAM350에서 Gerber & Drill Import  

19 

1 

2 

3 

TLW2011, Oct 2011 

File > Import > AutoImport 
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CAM350에서 Layer Type 설정 
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1 2 
Layer Type을 설정한다.  
Top/Bottom Layer는 반드시 설정해 주어야 한다. 

TLW2011, Oct 2011 

Tables > Layers 
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CAM350에서 Gerber Netlist 추출 
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1 2 

TLW2011, Oct 2011 

Utilities > Netlist Extract 
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CAM350에서 IPC Netlist Import 
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1 2 

3 

TLW2011, Oct 2011 

File > Import > IPC > IPC-D-356 



©  2010 Mentor Graphics Corp.  

www.mentor.com/pcb 

CAM350에서 Gerber Netlist와 IPC Netlist 비교 
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1 2 

3 

4 

TLW2011, Oct 2011 

Analysis > Nets > Compare External Nets 
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CAM350에서 Gerber Netlist와 IPC Netlist 비교 
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5 6 
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Open 상태 Short 상태 
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Differential View 

 Expedition PCB에서는 PCB와 Gerber data를 비교하는 

기능 외에도 PCB 데이터간 직접 비교하는 Differential 

View 기능이 있습니다. 

 

26 

1 ToolBar의 Differential View를 실행하거나 
2 Analysis and DRC > Differential View

를 실행합니다. 

TLW2011, Oct 2011 
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Differential View 

27 

3 Differential View창에서 File > Compare 를 선택합니다. 

TLW2011, Oct 2011 
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Differential View 

28 

4 비교 Settings에서 비교할 대상 PCB와 비교 
조건을 선택합니다. 

TLW2011, Oct 2011 

 현재 open된 PCB는 ROM8_LP2의 PCB -> A 

 비교할 PCB는 ROM8_LP의 PCB -> B 

 Option : Do not crate A+B data 

    A와 B의 and(논리연산)한 data를 

생성합니다. (이 부분은 Check하여 생성하지 

않도록 합니다.) 

 Object type : 비교하고자 하는 Object를 

선택합니다. 기본적으로 Trace, Pad, Via를 

선택합니다. 

 Layer: 모든 Layer를 비교시 <All Layers>를 

선택하고 특정 Layer를 비교시에는 원하는 

Layer를 선택합니다. 

 Net: 모든 Net을 비교시 <All Nets>를 선택하고 

특정 Net을 비교시에는 원하는 Net을 

선택합니다. 
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Differential View 

29 

5  Compare를 실행한 결과를 확인합니다. 

TLW2011, Oct 2011 

여기서 View setting은 B-A
를 선택하여 수정 전 데이터에
서 현재 데이터의 차이점만 확
인하도록 합니다. 
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Differential View 

30 TLW2011, Oct 2011 

참고. 
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Differential View 

31 

6 비교 예제입니다. 빨간색 부분이 수정 전 데이터의 형상입니다. 

TLW2011, Oct 2011 
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Differential View 

32 

7 Differential View를 실행했을 때 Display Control에 추가된 Layer입니다. 

TLW2011, Oct 2011 
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Script to compare two keyin netlists 

 PCB keyin netlist 
— Forward Annotation이 완료되면 ../PCB/Logic/netlist.aug 파일 생성 

 Schematic keyin netlist 
— DxDesigner using File > Export > Keyin Netlist 

 사용법 
— Compare.vbs Anetlist.kyn Bnetlist.kyn [refdes prefix to ignore] 

 스크립트 다운로드 
— http://communities.mentor.com/mgcx/docs/DOC-2207 
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Script to compare Boardstation nets file to 
translated Dx/Expedition CES 

 The script compares the Boardstation nets.nets file to the 

CES connectivitySchematic keyin netlist 

 스크립트 다운로드 
— http://communities.mentor.com/mgcx/docs/DOC-1820 

TLW2011, Oct 2011 35 
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ConnectivityCheck.zip  파일을 압축 해제한 후 ConnectivityCheck.vbs  파일을 WDIR 디렉
터리인 C:\WDIR에 위치시킨다. 

CES를 실행해서, Command Line 툴 바를 Open한다. 

 

 

 

Script to compare Boardstation nets file to 
translated Dx/Expedition CES 
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Command Line 툴바에서 ConnectivityCheck.vbs 를 입력하고 Enter한다. 

 

 

 

 

 

 

 

 

 

Board Station PCB 폴더를 선택하는 윈도우에서 해당 소스 디자인의 PCB 폴더를 선택한다. 

 

 

Script to compare Boardstation nets file to 
translated Dx/Expedition CES 
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비교 실행 결과가 Output 윈도우 System 탭에 출력된다. 

 

 

 

Script to compare Boardstation nets file to 
translated Dx/Expedition CES 
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Agenda 

 Oracle 사용환경구성 

 Oracle Client 설치 및 설정 

 Oracle database 구성 최적화 

41 TLW2011, Oct 2011 
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ORACLE 사용환경구성 

42 



©  2010 Mentor Graphics Corp.  

www.mentor.com/pcb 

Oracle 사용환경구성 

 DxDatabook과 Oracle 데이터베이스를 ODBC로 연계해서 

사용환경을 구성하는 방법 

 “제어판 > 관리 도구 > 데이터 원본 (ODBC)” 등록 불 필요 

TLW2011, Oct 2011 43 
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Oracle Server 환경 설정 

 Oracle 데이터베이스로 사용할 서버에 Oracle 9i or 10g를 

설치한다. 

 Tablespace와 Schema를 생성하고, 사용자 권한을 설정한다. 

Web을 통해 제공되는 Oracle Enterprise Manager를 사용하면 

용이하게 구성할 수 있음. Login시 SYSDBA로 접속하여야 함. 

44 TLW2011, Oct 2011 
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Oracle Server 환경 설정 

 Library Partition별로 Table를 생성합니다. 

45 

CREATE TABLE "ROMEO"."micro_proc" ( "ID" VARCHAR2(100), 
"PART_NUMBER" VARCHAR2(255), "PART_NAME" VARCHAR2(255), 
"PART_LABEL" VARCHAR2(255), "DESCRIPTION" VARCHAR2(255), 
"STATUS" VARCHAR2(50), "SYMBOL" VARCHAR2(255)) TABLESPACE 
“MY_DB"; 

TLW2011, Oct 2011 



©  2010 Mentor Graphics Corp.  

www.mentor.com/pcb 

Oracle Server 환경 설정 

 PDB에서 csv 파일을 추출하거나, LMS Catalog에서 csv 파일을 

추출한다. 

 MDB를 사용하고 있으면 Oracle에서 Migration Kit를 

제공하고 있으므로 해당 프로그램을 사용해서 MDB를 Oracle로 

Migration 해도 된다. 
— http://www.oracle.com/technology/tech/migration/focusareas/access.html 
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http://www.oracle.com/technology/tech/migration/focusareas/access.html
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Oracle Server 환경 설정 

 추출된 csv 파일을 sqlldr 명령을 사용해서 해당 Table에 Import 

한다. sqlldr은 control 파일이 필요하다. 
— Control 파일 micro_proc.ctl 예) 

 

 

 

 

 

 

 

 

 

— sqlldr 명령 예) 

 

sqlldr romeo/mentor control=micro_proc.ctl 
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load data  

infile 'c:\oracle\micro_proc.csv' 

replace  

into table "micro_proc" 

fields terminated by '^' 

trailing nullcols 

( ID, PART_NUMBER, PART_NAME, PART_LABEL, DESCRIPTION, 

STATUS, SYMBOL ) 

TLW2011, Oct 2011 
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Tip: DxDesigner에서 CL View를 보이지 않게 하는 
기능 

 DxDatabook에서 Properties 명령을 실행합니다. 

 

 

 

 

 

 “Do not show CL view….” 옵션을 체크해 주면 CL View가 보이지 

않게됩니다. 

 

48 

EE7.9.1 버전에서부터 적용  

TLW2011, Oct 2011 
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Tip: DxDesigner에서 CL View를 보이지 않게 하는 
기능 

 프로젝트 최초 생성시 자동으로 CL View를 보이지 않게 적용하는 환경구성 

 

Corp_Config\DxDesigner.xml 파일을 텍스트 에디터로 열어서  

<settings> 항목 내에 DXDB_HIDE_CL_VIEW의 value를 1로 정의해 줍니다. 

  

<settings> 

… 

… 

<key name="DXDB_HIDE_CL_VIEW" value="1"/> 

… 

… 

</settings> 

  

Note: Show (value="0"/) or hide (value="1"/) CL View. 
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ORACLE CLIENT 설치 및 설정 

50 
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Oracle Client 설치 및 설정 

 Oracle 서버 버전에 맞는 Oracle Client 프로그램을 설치한다. 
— http://www.oracle.com/technology/software/tech/oci/instantclient/htdocs/winsoft.html  

 압축파일을 다운로드 해서 c:\oracle\instantclient 와 같은 

경로로 압축해제한다. ODBC까지 다운로드해서 설치한다. 

 C:\oracle\instantclient 폴더 내에 서버에서 사용 중인 

tnsnames.ora 파일을 복사 또는 생성해 주어야 한다.  

 환경변수에 다음과 같이 추가해 준다. 
— PATH=c:\oracle\instantclient;<기존 값> 

— TNS_ADMIN=c:\oracle\instantclient 
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http://www.oracle.com/technology/software/tech/oci/instantclient/htdocs/winsoft.html
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Oracle Client 설치 및 설정 

 DxDatabook Configuration 생성 
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ORACLE DATABASE 구성 최적화 
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Oracle database 구성 최적화 

 다음과 같은 환경구성을 가지고 DxDatabook속도비교 
1. Oracle, 네트워크 마운트된 Central Library사용 

2. Oracle, 로컬 PC로 복사된 Central Library사용 

3. 로컬에 보관된 MDB, 네트워크 마운트된 Central Library사용 

4. Oracle, 네트워크 마운트된 Central Library사용 (단, 부품 종류별로 

구분된 Oracle DB Table을 하나의 Table로 통합하고, PDB는 부품 종류 

별로 파티션이 구분되어 있어야 하므로 View Table을 부품 종류별로 

구성) 
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Oracle DB Central LIB Oracle DB 

Central LIB MDB 

Central LIB 
Oracle DB 

(통합 테이블) 
Central LIB 

1 2 3 4 
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